Dumb 725 Question

As I am clearly awesome, I will chalk this silly issue up to the meter being dumb and not me. Because, well, come on, it's me!

I have a Fluke 725, Firmware 2.xx that I am trying to send a source value to. Meter is set to mV Source and am trying to set it to 45mV. So my commands are as follows.

2.001 PORT [CLR]m[13]
2.002 PORT 45[13]

That always sets the meter to 4mV output. I have tried about every ASCII construction I can think of:

2.002 PORT 45.00[13]
2.002 PORT 4,5[13]
2.002 PORT 4,5,0,0[13]
2.002 PORT 4.5.0.0[13]

...and others. Still, only the 4 takes. I thought I was onto something playing with the inter-byte delay until I read in the Met/Cal manual that this only works with IEEE constructions. So... What am I missing?

Groups:

Comments

1376599284

Just had a look at the gold

Just had a look at the gold procedure code for a 725 F/W < 3

It looks like you have to send each char individually 

see below

 

  1.001  PORT         [P9600,N,8,1,N][T10000]


  1.002  MATH         @Millivolts = "45"

  1.003  MATH         @Command = "m" & @Millivolts & "\r"

  1.004  PORT         [CLR]

  1.005  MATH         L[1] = 1

  1.006  DO

  1.007  MATH         Char = SUB(@Command, L[1], 1)

  1.008  PORT         [V Char][D1000]

  1.009  MATH         L[1] = L[1] + 1

  1.010  UNTIL        L[1] > LEN(@Command)

  1.011  PORT         [13]

 

1488999028

Huh. I wouldn't have guessed

Huh. I wouldn't have guessed that. Thanks!

1376599284

Out of curiosity did it

Out of curiosity did it work?

Cheers

Nathan

1488999028

Yes it did! I haven't tried

Yes it did! I haven't tried every way it will and will not work but it seemed like the secret here was the 1 second delay between characters. Even something as basic as this seems to work:

PORT 4[D1000]5[D1000][13]

So, it appears to be the speed that the characters are sent. It is comical though, when sourcing 3600 Ohm that you have to wait a full 4 seconds for it to take.

1376599284

Good to know....I'll file

Good to know....I'll file that into the memory bank cheers